[Mac] login error

Comment below rating threshold, click here to show it.

Paddlesteamer

Junior Member

30-06-13

Hey all.

I am a mac user, and I have downloaded the official Mac Beta from the riot website (about?) 4 months ago when it became available on the riot website. I changed my region from NA to OCE and managed to play three games yesterday. My issue is that when I try to login i receive a 'login error', after 3 attempts to connect to the login server my client gives up and i must reenter password and attempt again...

I made a new NA account and logged into NA fine straight away with no issues, but yeah just want to play OCE since Melb. based...

Anyway, I get its a beta, not raging just really want to play the game we all love.

Inb4 shouldn't have bought a mac.

Regards!


Comment below rating threshold, click here to show it.

MrGrandandor

Junior Member

30-06-13

I am having the same problem and i think i couldnt log in after 3 games too. And i also logged into my smurf acount on NA and it worked fine aswell.

Just hope Riot fixes it, and nice to know that its not just me having problems.


Comment below rating threshold, click here to show it.

thearistocat

Junior Member

01-07-13

Don't worry, that happened to me and I found it only really occurred when there was major lag

i.e. my brother streaming videos

and it was really only happening last night now that I think about it


Just keep trying, it should eventually work for you


Comment below rating threshold, click here to show it.

MrGrandandor

Junior Member

01-07-13

When i am the only one using my internet it still have this problem. It could just be i got bad internet.


Comment below rating threshold, click here to show it.

thearistocat

Junior Member

01-07-13

Mac laptops tend to do that. They suck the data out of everything. I used to find it very hard to actually play a game without my ping reaching over 2000. I just downloaded "Little Snitch" which lets you control the internet traffic and what applications have access to it.


Comment below rating threshold, click here to show it.

SkinnyPhat

Junior Member

01-07-13

This happened to me today. I just retried logging in a few times and I think on the 4th? time I got in.


Comment below rating threshold, click here to show it.

Paddlesteamer

Junior Member

01-07-13

Yeah i still cant get on...

Last night I was at a friends house and was able to play there, but I can't at home.
Assuming its some high latency issue? but I can login to NA still straight away...

help meh pls


Comment below rating threshold, click here to show it.

Mit

Junior Member

07-07-13

I still have this problem but do this to get on. Try opening internet explorer and logging on the league of legends website (oce) and then logging in with the client. It sounds a bit strange but it worked for me.


Comment below rating threshold, click here to show it.

LexPlode

Junior Member

08-07-13

Quote:
Originally Posted by The Mitmayn View Post
I still have this problem but do this to get on. Try opening internet explorer and logging on the league of legends website (oce) and then logging in with the client. It sounds a bit strange but it worked for me.

Can i do this with google chrome or JUST IE?